CVE-2022-22818GHSA-95RW-FX8R-36V6BIT-DJANGO-2022-22818PYSEC-2022-19
The {% debug %} template tag in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2 does not properly encode the current conte
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.2.27, 3.2.12, 4.0.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
The {% debug %} template tag in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2 does not properly encode the current context. This may lead to XSS.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- djangoPyPI
From 2.2 · fixed in 2.2.27
- djangoPyPI
From 3.2 · fixed in 3.2.12
- djangoPyPI
From 4.0 · fixed in 4.0.2
- djangoPyPI
From 2.2 · fixed in 2.2.27; From 3.2 · fixed in 3.2.12; From 4.0 · fixed in 4.0.2