Skip to main content
← All vulnerabilities
CVE-2022-2270

An issue has been discovered in GitLab affecting all versions starting from 12.4 before 14.10.5, all versions starting from 15.0 before 15.0

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.10.5, 15.0.4, 15.1.1
None on Exploit-DB, Metasploit or GitHub

Summary

An issue has been discovered in GitLab affecting all versions starting from 12.4 before 14.10.5, all versions starting from 15.0 before 15.0.4, all versions starting from 15.1 before 15.1.1. GitLab was leaking Conan packages names due to incorrect permissions verification.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 12.4 · fixed in 14.10.5; From 15.0 · fixed in 15.0.4; From 15.1 · fixed in 15.1.1

References 3

gitlab.com

hackerone.com