CVE-2022-22577GHSA-MM33-5VFQ-3MM3
An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.2.7.1, 6.0.4.8, 6.1.5.1, 7.0.2.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a https://github.com/rails/rails
Version range not reported
- actionpackRubyGems
From 5.2.0 · fixed in 5.2.7.1
- actionpackRubyGems
From 6.0.0 · fixed in 6.0.4.8
- actionpackRubyGems
From 6.1.0 · fixed in 6.1.5.1
- actionpackRubyGems
From 7.0.0 · fixed in 7.0.2.4