Skip to main content
← All vulnerabilities
CVE-2022-2229

An improper authorization issue in GitLab CE/EE affecting all versions from 13.7 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 1

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.10.5, 15.0.4, 15.1.1
None on Exploit-DB, Metasploit or GitHub

Summary

An improper authorization issue in GitLab CE/EE affecting all versions from 13.7 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 allows an attacker to extract the value of an unprotected variable they know the name of in public projects or private projects they're a member of.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 13.7 · fixed in 14.10.5; From 15.0 · fixed in 15.0.4; From 15.1 · fixed in 15.1.1

References 3

gitlab.com

hackerone.com