Skip to main content
← All vulnerabilities
CVE-2022-22162

Junos OS: A low privileged user can elevate their privileges to the ones of the highest privileged j-web user logged in

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.1R7-S11, 18.3R3-S6, 19.3R3-S4, 19.4R3-S6, 20.1R3-S2, and 3 more
None on Exploit-DB, Metasploit or GitHub

Summary

A Generation of Error Message Containing Sensitive Information vulnerability in the CLI of Juniper Networks Junos OS allows a locally authenticated attacker with low privileges to elevate these to the level of any other user logged in via J-Web at this time, potential leading to a full compromise of the device. This issue affects Juniper Networks Junos OS: All versions prior to 15.1R7-S11; 18.3 versions prior to 18.3R3-S6; 18.4 versions prior to 18.4R2-S9, 18.4R3-S10; 19.1 versions prior to 19.1R2-S3, 19.1R3-S7; 19.2 versions prior to 19.2R1-S8, 19.2R3-S4; 19.3 versions prior to 19.3R3-S4; 19.4 versions prior to 19.4R3-S6; 20.1 versions prior to 20.1R3-S2; 20.2 versions prior to 20.2R3-S3; 20.3 versions prior to 20.3R3-S1; 20.4 versions prior to 20.4R3-S1; 21.1 versions prior to 21.1R2-S1, 21.1R3; 21.2 versions prior to 21.2R1-S1, 21.2R2.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Juniper Networks Junos OS

    fixed in 15.1R7-S11; From 18.3 · fixed in 18.3R3-S6; From 19.3 · fixed in 19.3R3-S4; From 19.4 · fixed in 19.4R3-S6; From 20.1 · fixed in 20.1R3-S2; From 20.2 · fixed in 20.2R3-S3; From 20.3 · fixed in 20.3R3-S1; From 20.4 · fixed in 20.4R3-S1

References 1

kb.juniper.net