Skip to main content
← All vulnerabilities
CVE-2022-21951GHSA-VRPH-M5JJ-C46C

Rancher: Weave CNI password is not set if RKE template is used with CNI value overridden

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.5.14, 2.6.5
None on Exploit-DB, Metasploit or GitHub

Summary

A Cleartext Transmission of Sensitive Information vulnerability in SUSE Rancher, Rancher allows attackers on the network to read and change network data due to missing encryption of data transmitted via the network when a cluster is created from an RKE template with the CNI value overridden This issue affects: SUSE Rancher Rancher versions prior to 2.5.14; Rancher versions prior to 2.6.5.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • SUSE Rancher

    From Rancher · fixed in 2.5.14

  • SUSE Rancher

    From Rancher · fixed in 2.6.5

  • github.com/rancher/rancherGo

    From 2.6.0 · fixed in 2.6.5

  • github.com/rancher/rancherGo

    From 2.5.0 · fixed in 2.5.14

References 2

bugzilla.suse.com

GitHub · rancher/rancher