CVE-2022-21831GHSA-W749-P3V6-HCCQ
A code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via image_processing argu
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.2.6.3, 6.0.4.7, 6.1.4.7, 7.0.2.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
A code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via image_processing arguments.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a https://github.com/rails/rails
Version range not reported
- activestorageRubyGems
From 5.2.0 · fixed in 5.2.6.3
- activestorageRubyGems
From 6.0.0 · fixed in 6.0.4.7
- activestorageRubyGems
From 6.1.0 · fixed in 6.1.4.7
- activestorageRubyGems
From 7.0.0 · fixed in 7.0.2.3