CVE-2022-20616GHSA-GQM2-2GCX-P88W
Jenkins Credentials Binding Plugin 1.27 and earlier does not perform a permission check in a method implementing form validation, allowing a
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.27.1, 1.24.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Jenkins Credentials Binding Plugin 1.27 and earlier does not perform a permission check in a method implementing form validation, allowing attackers with Overall/Read access to validate if a credential ID refers to a secret file credential and whether it's a zip file.
Timeline
- CVE published
- Record last updated
Affected versions
- Jenkins project Jenkins Credentials Binding Plugin
through 1.27
- org.jenkins-ci.plugins:credentials-bindingMaven
From 1.25 · fixed in 1.27.1
- org.jenkins-ci.plugins:credentials-bindingMaven
fixed in 1.24.1