Skip to main content
← All vulnerabilities
CVE-2022-20612GHSA-P92Q-7FHH-MQ35BIT-JENKINS-2022-20612

A cross-site request forgery (CSRF) vulnerability in Jenkins 2.329 and earlier, LTS 2.319.1 and earlier allows attackers to trigger build of

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.330, 2.319.2
None on Exploit-DB, Metasploit or GitHub

Summary

A cross-site request forgery (CSRF) vulnerability in Jenkins 2.329 and earlier, LTS 2.319.1 and earlier allows attackers to trigger build of job without parameters when no security realm is set.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Jenkins project Jenkins

    through 2.329; through LTS 2.319.1

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.320 · fixed in 2.330

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.319.2

References 3

jenkins.io

openwall.com

oracle.com