Skip to main content
← All vulnerabilities
CVE-2022-2047GHSA-CJ7V-27PG-WF7Q

In Eclipse Jetty versions 9.4.0 thru 9.4.46, and 10.0.0 thru 10.0.9, and 11.0.0 thru 11.0.9 versions, the parsing of the authority segment o

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.4.47, 10.0.10, 11.0.10
None on Exploit-DB, Metasploit or GitHub

Summary

In Eclipse Jetty versions 9.4.0 thru 9.4.46, and 10.0.0 thru 10.0.9, and 11.0.0 thru 11.0.9 versions, the parsing of the authority segment of an http scheme URI, the Jetty HttpURI class improperly detects an invalid input as a hostname. This can lead to failures in a Proxy scenario.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • The Eclipse Foundation Eclipse Jetty

    From 9.4.0; through 9.4.46; From 10.0.0; through 10.0.9; From 11.0.0; through 11.0.9

  • org.eclipse.jetty:jetty-httpMaven

    fixed in 9.4.47

  • org.eclipse.jetty:jetty-httpMaven

    From 10.0.0 · fixed in 10.0.10

  • org.eclipse.jetty:jetty-httpMaven

    From 11.0.0 · fixed in 11.0.10

References 4

GitHub · eclipse/jetty.project

debian.org

lists.debian.org

security.netapp.com