Skip to main content
← All vulnerabilities
CVE-2022-1954

A Regular Expression Denial of Service vulnerability in GitLab CE/EE affecting all versions from 1.0.2 prior to 14.10.5, 15.0 prior to 15.0.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.10.5, 15.0.4, 15.1.1
None on Exploit-DB, Metasploit or GitHub

Summary

A Regular Expression Denial of Service vulnerability in GitLab CE/EE affecting all versions from 1.0.2 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1 allows an attacker to make a GitLab instance inaccessible via specially crafted web server response headers

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 1.0.2 · fixed in 14.10.5; From 15.0 · fixed in 15.0.4; From 15.1 · fixed in 15.1.1

References 3

gitlab.com

hackerone.com