Skip to main content
← All vulnerabilities
CVE-2022-1944

When the feature is configured, improper authorization in the Interactive Web Terminal in GitLab CE/EE affecting all versions from 11.3 prio

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.9.5, 14.10.4, 15.0.1
None on Exploit-DB, Metasploit or GitHub

Summary

When the feature is configured, improper authorization in the Interactive Web Terminal in GitLab CE/EE affecting all versions from 11.3 prior to 14.9.5, 14.10 prior to 14.10.4, and 15.0 prior to 15.0.1 allows users with the Developer role to open terminals on other Developers' running jobs

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 11.3 · fixed in 14.9.5; From 14.10 · fixed in 14.10.4; From 15.0 · fixed in 15.0.1

References 2

gitlab.com