Skip to main content
← All vulnerabilities
CVE-2022-1935

Incorrect authorization in GitLab EE affecting all versions from 12.0 before 14.9.5, all versions starting from 14.10 before 14.10.4, all ve

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.0.1, 14.10.4, 14.9.5
None on Exploit-DB, Metasploit or GitHub

Summary

Incorrect authorization in GitLab EE affecting all versions from 12.0 before 14.9.5, all versions starting from 14.10 before 14.10.4, all versions starting from 15.0 before 15.0.1 allowed an attacker already in possession of a valid Project Trigger Token to misuse it from any location even when IP address restrictions were configured

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 15.0.0 · fixed in 15.0.1; From 14.10.0 · fixed in 14.10.4; From 12.0.0 · fixed in 14.9.5

References 2

gitlab.com